Reliance Netconnect Broadband+ in Linux

Empathy for WVDIAL users

Posted on: March 27, 2010

Empathy

Empathy Instant Messenger

Empathy by default only works with connections that are connected using Network Manager . When using Wvdial Empathy does not detect the network and so does not work . There is a work around for this problem .

Procedure :

Step 1: Open a terminal and enter

gconf-editor

Step 2: Go to “apps > empathy”

Step 3: uncheck the box “use_conn”

Step 4: Close the windows

Empathy should detect your Wvdial connection and you should be able to connect to your IM IDs now.

Before you use your Gtalk ID in Empathy you may have to make a few changes for a successful connection .

Procedure :

Step 1: Click “Add” to add a new account .

Step 2: Select “Gtalk” in th Add New drop down box

Step 3: Click on the “Create” button

Step 4: Enter your login and password.

Step 5: Click on the advanced tab

Step 5: Check the Encryption required (TSL/SSL) checkbox

Step 6: Enter “talk.google.com” in the server textbox

Step 7: Click Connect

To delete an account just click on the small bin icon displayed to the right of each account .

Advertisements

1 Response to "Empathy for WVDIAL users"

Facing problem in connecting Reliance Netconnect Broadband+ (Huawei EC1260) to internet on Ubuntu 8.04.

I configured the /etc/wvdial.conf as follows :

===================
[Dialer Defaults]
Init1 = ATZ
Password =
Phone = #777
Stupid Mode = 1
Modem = /dev/ttyUSB0
Username =
New PPPD = yes
Baud = 460800
===================
In this case both username & password are same as the MDN.

When I use “sudo wvdial” for connection, I get following output :
=============
amit@amit-laptop:$sudo wvdial
–> WvDial: Internet dialer version 1.60
–> Cannot get information for serial port.
–> Initializing modem.
–> Sending: ATZ
ATZ
OK
–> Modem initialized.
–> Sending: ATDT#777
–> Waiting for carrier.
ATDT#777
CONNECT
–> Carrier detected. Starting PPP immediately.
–> Starting pppd at Wed Apr 14 16:55:11 2010
–> Pid of pppd: 7074
–> Using interface ppp0
–> pppd: ��[06][08]
–> pppd: ��[06][08]
–> pppd: ��[06][08]
–> pppd: ��[06][08]
–> pppd: ��[06][08]
–> local IP address 115.240.100.7
–> pppd: ��[06][08]
–> remote IP address 220.224.141.129
–> pppd: ��[06][08]
–> primary DNS address 202.138.97.193
–> pppd: ��[06][08]
–> secondary DNS address 202.138.96.2
–> pppd: ��[06][08]
================

I am not sure why am I getting junk character in the ppp log above.

I use “ifconfig” to see there a new interface “ppp0” is created and an IP is assigned to it.

But I can not ping the remote IP mentioned above in ppp log. Neither can I connect to internet. I do not have “work offline” enabled in Firefox I use.

Can you help me out ?

Reply :
Your ping packets are not crossing your gateway . Do you have a software or router firewall enabled ? Try pinging 8.8.8.8 (Googl
e’s DNS server)

Comments are closed.

%d bloggers like this: